Stardock

Steam Workshop Crash

By on August 2, 2015 11:16:47 AM from Stardock Forums Stardock Forums

dracoes

Join Date 05/2012
0

Whenever I try to use a design from the Steam Workshop, the game crashes back to the desktop. When I open the designer, I can see the design as expected under the "Downloaded" heading, but as soon as I click one, the crash occurs.

When I subsequently open the game again, all the user designed ships have vanished from the designer, even my own which have not been downloaded from the workshop. I have checked, and I am still subscribed to the ones in the workshop. I can make them re-appear by unsubscribing and subscribing again, but this just repeats the crash if I try to select them, and obviously does not restore my own designs.

Has anyone else experienced this problem, or know of a fix?

3 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
August 2, 2015 2:13:52 PM from Galactic Civilizations III Forums Galactic Civilizations III Forums

Have you just upgraded to Windows 10? Many problems are being reported after upgrading to Win10 and a few suggestions have helped. Look at Windows 10 - Cannot Save Game » Forum Post by michaelguillory55  for instance. Also, there has been some mention of doing a "clean install", which may bear looking into what it entails and what the consequences may be.

 

EDIT: After looking at it, I don't think I like the "clean install" procedure. It looks like it is a lot like burning one's bridges behind ones self. I would like to hear from someone that has had first hand experience with this.

Reason for Karma (Optional)
Successfully updated karma reason!
August 3, 2015 1:30:36 PM from Stardock Forums Stardock Forums

Thanks for the response.  No, I'm still using Windows 7 Home Premium with SP1.

Reason for Karma (Optional)
Successfully updated karma reason!
August 3, 2015 3:13:45 PM from Galactic Civilizations III Forums Galactic Civilizations III Forums

I had a rash of problems with Steam Workshop last week. Could not upload ship designs, disappearing factions, etc. I was going nuts trying to figure it out, including submitting a ticket to support. Suddenly, it all seems to be working again. Go figure...

In looking at old posts on Steam, it seems that the workshop has a tendency to go sideways occasionally and all you can do is wait it out.

Totally different thing and doesn't sound like your problem, but I downloaded some Dune factions that were causing a crash due to the maker not including a ship style for the factions.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000859   Page Render Time:
Facebook Twitter YouTube Google+