Stardock

New Install - Updated 1.4 version MAJOR ISSUES! HELP!

By on August 10, 2012 7:07:16 AM from Elemental Forums Elemental Forums

shofoo

Join Date 04/2008
0

Hi! I just bought the game off the rack, finally figured out how to update and register the game. I downloaded the most recent version from Stardock and have installed it. Here are a couple of the issues I am having.

1) My mouse pointer does not display in the game. If i Alt-Tab, the mouse is working fine. I am able to see where the mouse is supposed to be by the way some icons highlight when selected by my 'invisible" mouse pointer. This in itself makes the game unplayable.

2.) I started a Campaign to see if maybe it was just a main menu glitch. After the intro cs, the main display is just a white screen, while the town is a black box. It is as if the game is unable to pull any images, as the character selection screen where there should be imagaes are all black boxes.

 

These 2 things alone make the game unplayable. My system in not 64 bit. I run Windows 7. All my drivers and system are up to date and I have no issues playing my 20 other games. Any help would be awesome!

 

 

 

2 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
August 10, 2012 9:28:57 AM from Elemental Forums Elemental Forums

E-mail support@stardock.com

Reason for Karma (Optional)
Successfully updated karma reason!
September 26, 2012 3:55:51 AM from Elemental Forums Elemental Forums


I'm having a similar issue, but mine is 64bit

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000359   Page Render Time:
Facebook Twitter YouTube Google+