Stardock

Performance Issues

By on July 18, 2012 3:30:13 PM from Elemental Forums Elemental Forums

Othello

Join Date 02/2008
+8

Does anyone else not notice a performance improvement between WoM & FE?

I'm running FE on the same laptop I would run WoM on and can see little if any discernible difference.

Everything starts getting sluggish about 40 turns into the game to the point of being a bothersome, even with all graphical options turned down/off.

Othello

6 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
July 18, 2012 8:42:59 PM from Elemental Forums Elemental Forums

How powerful is your laptop?  I have a desktop, and while I haven't done comparisons between FE speed and WoM speed, most of the time the game (FE) runs pretty well.

Reason for Karma (Optional)
Successfully updated karma reason!
July 19, 2012 12:21:09 AM from Elemental Forums Elemental Forums

The one i have it installed on is:

2ghz core2duo

4gb ram

nvidia 8600mgt

vista 64

What I'm surprised by is that I don't notice much improvement when, judging by the lack of complaints, things are running smooth for everyone else.

Othello

Reason for Karma (Optional)
Successfully updated karma reason!
July 19, 2012 4:58:55 AM from Elemental Forums Elemental Forums

If anything you are likely to notice a decrease in performance between E:wom and beta3 of FE. This is because FE is simply more demanding on your gpu as it has better graphics.

Now I'm going to speak plainly, and I don't mean this as an insult but as a dose of realism. If you are running a Nvidia 8600M GT card, don't expect much in terms of performance. The card is 6 years old and was a stripped down mobile version when it arrived. FE is a state-of-the-art computer game that hasn't even been released yet.

If you want to improve performance, try going to Options and click in "Disable outlines", "Disable particle effects" and "Disable pedestrians". Also make sure that you have Anti-Aliasing turned off, both inside the game and in the settings for your graphics card. The amount of Groundcover should also be set to normal, sparse or none.

Edit: I am assuming you have already turned down the resolution. But if you haven't, that's a good place to start.

Reason for Karma (Optional)
Successfully updated karma reason!
July 19, 2012 11:25:43 AM from Elemental Forums Elemental Forums

There's always cloth map!

Reason for Karma (Optional)
Successfully updated karma reason!
July 19, 2012 11:38:42 AM from Elemental Forums Elemental Forums

^^  Agreed.  I sometimes end up playing a whole game on the cloth map.  I like the statues and it runs better on my crappy work laptop that way.

Reason for Karma (Optional)
Successfully updated karma reason!
July 24, 2012 9:03:17 PM from Elemental Forums Elemental Forums

I play on a .... integrated intel 3000.  Yep.

 

It's a sandy bridge i5 macbook pro in bootcamp.

 

I have the same issue... the game runs perfectly smooth for like the first 50 turns.  Then... SUDDENLY (not gradually), the game gets very very laggy.  It's not really a drop in FPS... it feels more like when your hard drive is thrashing because you ran out of RAM.

 

I think this is an optimization problem for the game... your 8600m is fine in my opinion.  Perhaps beta 4 will be better.

 

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000188   Page Render Time:
Facebook Twitter YouTube Google+