Stardock

POE and Multiplicity

By on June 25, 2012 1:01:35 AM from Stardock Forums Stardock Forums

DarthZaketh

Join Date 04/2003
0

Well I work from home and company is going to VOIP phone system and sent me a Cisco 881 POE router for persistant VPN tunnel.  Well can't use Multiplicity with that.  Is there anyway to get it to work through router without having to have access to Router config?  I am assuming no there is not but just want to doublecheck.

 

Van

5 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
July 24, 2012 4:03:39 PM from Stardock Forums Stardock Forums

Its not clear what you are doing. Why would the router prevent you from working locally? Is is becuase you always are connected to the VPN on your main machine? I have used VPN  and was still able to resolve to my local network for Multiplicity to work. Just give each machine a static address on your net and then refer to them by that static address.

Reason for Karma (Optional)
Successfully updated karma reason!
September 10, 2012 5:59:37 PM from Stardock Forums Stardock Forums

I have an identical setup.  As you are probably aware, the problem is that your VPN router is performing NAT (the router acts as a gateway between your home network and VPN'd network, just like how the router in your DSL/Cable modem acts between you and your ISP.   The only way to get  this to work is if you have access to your router config. - You'll need to forward the Multiplicity port from the 'WAN' side of your router (WAN being your home network) to your workstations IP address.

Here is the command i use:

ip nat inside source static tcp 10.30.1.68 30564 interface FastEthernet4 30564

Where

10.30.1.68 is the ip address of my workstation.

30564 is the port for Multiplicity

FastEthernet4 is the name of my WAN interface

 

From here you need to add the IP address that your home network router assigned to the WAN port of your VPN router as a computer in multiplicity.

DHCP for this can be a bear, so I'd recommend either assigning static IPs to your VPN router's WAN port and workstation, or use a static MAC reservation.  If DHCP switches the IP addresses on you, you will need to modify the router config. 

 

 

Here is a script you can run on the router in the event your workstation's IP address changes. - .67 is my old ip address, .68 is the new one.

en

<ROUTER ENABLE PASSWORD>

 

 

config t

interface FastEthernet4

no ip nat outside

do clear ip nat translation *

end

config t

no ip nat inside source static tcp 10.31.1.67 30564 interface FastEthernet4 30564

ip nat inside source static tcp 10.31.1.68 30564 interface FastEthernet4 30564

interface FastEthernet4

ip nat outside

 

 

 

end

exit



Hope this helps someone!

Reason for Karma (Optional)
Successfully updated karma reason!
September 11, 2012 11:36:54 AM from Stardock Forums Stardock Forums

Nice!  Thanks.

Reason for Karma (Optional)
Successfully updated karma reason!
September 17, 2012 4:35:10 PM from Stardock Forums Stardock Forums

Quoting ScottAdams,
Its not clear what you are doing. Why would the router prevent you from working locally? Is is becuase you always are connected to the VPN on your main machine? I have used VPN  and was still able to resolve to my local network for Multiplicity to work. Just give each machine a static address on your net and then refer to them by that static address.

 

It is quite possible that the router IS actually the culprit.

If the router is providing persistent VPN services to the client, it may well be disabling internal routing on the local machine. It's similar (in function) to the way 'wireless isolation' prevents multiple wireless users (like in a public hotel for example) from being able to communicate with each other even though they are on the same IP subnet.

1. Do you plug directly in to the router from any of the machines or do any/all of your machines plug in to a switch/hub and then from the switch to the VPN router ?

2. Can you PING between workstations when the router is DISCONNECTED ? If so, does the ping STOP working when you plug the VPN router in ?

If the answer to both of the questions in #2 are YES, then you are probably out of luck, unless the security administrator at your place of work is a LOT more lax with security than I would be in his situation.

It is also worth verifying that the VPN itself is actually working. If it isn't, it may indicate an entirely different set of problems with your topology.

= K

Reason for Karma (Optional)
Successfully updated karma reason!
October 11, 2012 9:12:55 AM from Stardock Forums Stardock Forums

You might be able to do it this way. I had the same problem and overcame it by getting 2 usb network cards and a cross-over cable. I installed the two network cards (one in each computer) and assigned each of them a static ip address and subnet mask and then connected them with a cross over cable. I did have to give multiplicity the ip address instead of the computer name and it worked just fine. If you want more information on how to do it this way let me know. 

 

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000454   Page Render Time:
Facebook Twitter YouTube Google+