Stardock

[.90 CRASH] When attempting to open diplomacy.

By on April 19, 2012 10:05:55 PM from Elemental Forums Elemental Forums

Frabulon

Join Date 02/2008
+6

I've had this in both games I've started. At first three times with Tarth before I discarded that game, then in a second game with Relias. First contact goes fine, but when I actually attempt to talk to someone--crash.

http://dl.dropbox.com/u/68660820/FallenEnchantress0_90-2012-04-19T18-31-46-204.zip

http://dl.dropbox.com/u/68660820/FallenEnchantress0_90-2012-04-19T18-35-38-146.zip

http://dl.dropbox.com/u/68660820/FallenEnchantress0_90-2012-04-19T19-02-18-465.zip

http://dl.dropbox.com/u/68660820/FallenEnchantress0_90-2012-04-19T19-48-53-773.zip

I installed from the patch if that is the culprit.

29 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 2:54:17 AM from Elemental Forums Elemental Forums

I can confirm this crash. I, too, installed from patch. I haven't ever managed to start a diplomatic conversation.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 5:19:14 AM from Elemental Forums Elemental Forums

Same error. Here's an alternate autosave and debug to help correlate:

https://docs.google.com/open?id=0Bwqxr2VI19bQck9hT2NOUWtESnM

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 9:57:07 AM from Elemental Forums Elemental Forums

I got the same crash.  Sent my report in to support via email.  I also installed via the patch, instead of a new install if that matters.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 11:28:06 AM from Elemental Forums Elemental Forums

I can't reproduce this crash from the save games that VRBones and stevelamperti sent in.  Do your version screens say 0.90?  The crash dumps seem to match up with the build we made yesterday, but the crash is in the same location as a crash I fixed at least a week ago. 

You guys can verify this crash from your save games, right? It doesn't just happen with new games?

Also, is anyone getting this crash with a fresh install?

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 11:33:59 AM from Elemental Forums Elemental Forums

I've used diplomacy both by clicking the AI player in the upper right of the main screen, and by right-clicking on an AI unit.  Had no crashes with this, either in .86 or .90, though my game's crashed twice on unit movement in 126 turns, thus far.

 

I'm not writing this to contradict anybody, but to point out that the bug appears not to be general.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 2:37:59 PM from Elemental Forums Elemental Forums

For me the crash happens 100% reliably, saved game or new game. I think I have never seen the diplomacy screen - it just doesn't work. I tried to reset the settings I have changed, but it didn't help. I am downloading the full game and will try a reinstall next.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 3:36:16 PM from Elemental Forums Elemental Forums

I reinstalled the game and now the diplomacy screen works. FWIW the md5sum of the .90 patch I installed is: 3c96512b9fd2719848112328390b75ee (copied by hand, typos possible). I have been updating by patches all the way from beta1.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 3:53:36 PM from Elemental Forums Elemental Forums

my saved game reproduces the problem 100% for me.  I'm guessing the problem has something to do with patching.  I'll try a full install tonight.  It did say .90 on the startup screen.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 5:09:00 PM from Elemental Forums Elemental Forums

Same thing happens to me two - tried two new games and when i try to open diplomacy it crashes - will do a full download and try a completely fresh install as well

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 5:38:06 PM from Elemental Forums Elemental Forums

I was having this issue too. In particular with trying to talk to Tarth. I also upgraded via the patch and I could reproduce it quite readily and easily from my saves.

 

A complete reinstall from the full download fixed it, even for the old saves which were crashing every time before.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 6:24:02 PM from Elemental Forums Elemental Forums

100% crash from diplomacy screen from .9 update

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 7:13:37 PM from Elemental Forums Elemental Forums

 

  If someone with this issue doesn't mind a bit of troubleshooting (and wants to avoid downloading and installing the whole game) would you please try deleting your "C:\ProgramData\Stardock\Elemental - Fallen Enchantress\Screens" directory?

  The game will recreate it next to you start to play.  This will tell us if the screen cache isn't picking up the patch changes.

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 7:45:32 PM from Elemental Forums Elemental Forums

Same as the others - no crashes after a clean install. I can't check just the  "C:\ProgramData\Stardock\Elemental - Fallen Enchantress\Screens" deletion as as I had already uninstalled and reinstalled before seeing the notice.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 8:15:23 PM from Elemental Forums Elemental Forums

Hi, I tried this (removing the Screens directory in "C:\ProgramData\Stardock\Elemental - Fallen Enchantress\Screens") and it did not work and I updated the game to 9.0 via the patch. Also, a new screens directory was not remade for me either.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 8:36:17 PM from Elemental Forums Elemental Forums


In contrast to the above poster, when I tried this it worked.  Deleting the screens directory before launching the application fixed the crash for me.

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 8:59:39 PM from Elemental Forums Elemental Forums

Hmm well I tried also uninstalling and re installing .86 and patching with .91, and I was able to replicate the same crash with the saved game. I will try a new game and see if it still happens.  Was really hoping to play tonight, meh instead I'm trying to figure out what the heck is wrong...

 

Edit 1: new game same issue...

Anyways I'm tired of troubleshooting, here's my debug file. http://dl.dropbox.com/u/31501549/debug.err

Reason for Karma (Optional)
Successfully updated karma reason!
April 20, 2012 9:02:14 PM from Elemental Forums Elemental Forums

Deleted all files in \screens (not the directory) and it fixed this crash for me.

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 2:17:36 AM from Elemental Forums Elemental Forums

I have the same problem in 0.90/0.91 (updated from 0.86). I deleted the screens directory but now when I click on "New Game" the game gets stuck on the water ripple screen. Nothing happens. I also tried creating an empty screens folder again. Same result. I don't think the game regenerates the contents of that directory.

 

I guess I may end up biting the bullet and do a full re-install.

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 3:41:25 AM from Elemental Forums Elemental Forums

Have problems with diplomacy too, tried to delete the screens folder but that did not help (crashed when starting diplomacy, no matter how I started the diplomacy) I am currently reinstalling the game to see if that helps

Sincerely
~ Kongdej

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 3:52:59 AM from Elemental Forums Elemental Forums

Could it have anything to do with 0.86 mod remnants being still there?  I initially started up with some coremods and one other mod still active.  So I turned off mods, removed the coremod files, but then got a crash when starting a new game with 0.90.  I renamed the directories (both in C:\Users and in the install directory) so it would start new, and installed the full beta again, and was able to play.  So far no crashes, but only spent a few hours on the new 0.91 version so far.

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 4:51:44 AM from Elemental Forums Elemental Forums

Have uninstalled the game completely, then reinstalled, have fixed all MY problems with diplomacy

Sincerely
~ Kongdej

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 6:49:42 AM from Elemental Forums Elemental Forums

Quoting StevenAus,
Could it have anything to do with 0.86 mod remnants being still there?

I only have vanilla FE. 

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 6:51:25 AM from Elemental Forums Elemental Forums

Steven I dont run any mods and had problems

Sincerely
~ Kongdej

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 4:40:58 PM from Elemental Forums Elemental Forums

Well, I found my solution to this problem. I did an uninstall of .86, cleared my registry, and deleted the "Fallen Enchantress" folder in the My Games folder which is found in My Documents. Then reinstalled .86 and patched with .91 and the works for me now.

I have noticed a few glitches, like the HP bar not showing the right amount, severe latency in one fight and by turn 200ish (I have to double check this), I lost all in game sounds except the background music.

Reason for Karma (Optional)
Successfully updated karma reason!
April 21, 2012 7:24:51 PM from Elemental Forums Elemental Forums

I tried deleting the files in the screens folder, to no avail. Doing a clean reinstall.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000922   Page Render Time:
Facebook Twitter YouTube Google+