Stardock

Black Screen Workaround

By on March 19, 2012 5:14:04 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Yarlen

Join Date 01/2005
+194

(Updated - 4/23/12)

Thank to everyone's submissions we've been able to track this issue down for the vast majority of users. 

We've determined that this bug appears to be caused by older Nvidia drivers. If those having this issue can try updating their drivers directly from the Nvidia website for their chipset, that would be great. You must be using driver version 296.10 or higher.

The URL is: http://www.geforce.com/Drivers

Once your drivers are updated if you still hit the black screen crash on startup, please try setting your Nvidia driver as the preferred 3D device as shown here: http://screencast.com/t/RTo1NZaVM

If you could let us know if this works for you, that would be great.

Thank you in advance.

 

 

88 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
April 5, 2012 5:24:03 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I have an acer 4830TG-6808

i5-2450M

8GB

64-bit Win 7

The key is GeForce 540M. I've done everything everyone has said and finally after updating to 8.17.12.9610 this driver version the game worked. However once I quit the game, shut down my laptop and restarted it's back to the same ole nonsense of hearing the sound, seeing your mouse pointer but no visuals at all. very frustrating. Trinity works just fine on all settings.

 

Also I do hook up my laptop to different monitors depending on if at work or at home. Not that it matters too much as just on the laptop screen it really goes bonkers.

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 6, 2012 1:05:42 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I had this issue ONCE---the very first time I ran the game.

Now it just crashes at 3:17:00 for no reason.

Reason for Karma (Optional)
Successfully updated karma reason!
April 6, 2012 4:52:06 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I posted this in another Thread:

Hi,

i've read the post and i have a suggest. What if the players with the Mobile cards set this card to use in first place for 3D Applications? This is an option in the Nvidia Global Driver Settings. Per default the intel hd card is used to display 3D to help the battery stay longer. But it's only a guess.

There is a video on youtube which describes it:

http://youtu.be/xdWRwrH98YU

Regards,

Mike

Reason for Karma (Optional)
Successfully updated karma reason!
April 6, 2012 10:39:55 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I have it to

Reason for Karma (Optional)
Successfully updated karma reason!
April 6, 2012 1:52:05 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Quoting Leuthesius,
I had this issue ONCE---the very first time I ran the game.

Now it just crashes at 3:17:00 for no reason.

 

Send your save game file in so that they can analyze it internally.

Reason for Karma (Optional)
Successfully updated karma reason!
April 6, 2012 2:52:43 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

All,

This is what worked for me.  I have an GeForce GTX 580m.  I ensured the driver was up to date through the nvidia website.  In the nvidia control panel under "Manage 3d Settings and set PhysX Configuration" I ensure that the 3d settings, under global were set to high performance nvidia processor and the geforce driver was set under the physx configuration.  I also deleted the ironclad folder.  Guess what no black screen and I am playing the game!

Reason for Karma (Optional)
Successfully updated karma reason!
April 7, 2012 2:09:14 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Dear guys, I dun think I solved it for everyone, but I think there is a Windows-related error with this. I had Diplomacy since like 2009, played it well, tried a ton of mods on it, gave them up, so basically a lot of changes and all went well.

 

Suddenly, one day it would just not enter. Reinstalled... nothing new. Forgot about Diplomacy around last year's December.

 

Bought Rebellion. Worked on campus laptop I have at University. Came back to me home town, installed it on me way-better-PC" . . . Guess what? Hell no, black screen bug affected it too. :/

 

Took on me usual weapon: regestry cleansers, used CCleaner, bought RegTweaker, fixed all errors they found, Virus/Rootkit scan, etc. (no defrag yet). Laptop felt as new. Done so at home, guess what, I got rid of dem bug.

 

Me opinion? It could be no game-related bug, which can be explained by why dem devs didn't find the source yet

 

I tried it and it worked ^.^

Cheers!

(Hopefully one will give me a link or sth related to some new Advent PvP builds as thanks and hope it will work fer ya)

Reason for Karma (Optional)
Successfully updated karma reason!
April 7, 2012 6:03:39 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Actually, I had this problem and managed to resolve it, I have an NVIDIA Geforce GT 55M card with an Intel HD Graphics 3000 series. I took the recommended steps (running in windowed mode etc) and they all failed. I found that going to the NVIDIA control panel, and changing the 'high performance processor' setting to 'integrated graphics' fixed the problem completely. Ironclad, the problem is somewhere in how NVIDIA is being handled. Hope this helped. If you want more info, like the dumps, e-mail me.

Reason for Karma (Optional)
Successfully updated karma reason!
April 9, 2012 8:43:05 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I was getting black start up crashes and just re-verified my game files through steam and it said 1 file failed to verify and would be reacquired. After that the game started up fine. Don't know if this is the same black screen bug though seeing as its an easy fix and has not been mentioned yet.

Reason for Karma (Optional)
Successfully updated karma reason!
April 10, 2012 8:44:57 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I have been having this problem, went to defrag my hard drive and the files for Rebellion are very fragmented but I presume that is a fault on my end.

 

Unlike the others I'm not using a mobile GPU

Reason for Karma (Optional)
Successfully updated karma reason!
April 10, 2012 3:56:12 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

The solid workaround solution so far seems to be disabling the Nvidia graphics chipset and running with Intel integrated only. Has anyone else tried updating to the new Nvidia beta driver and seeing if that resolved the issues?

Reason for Karma (Optional)
Successfully updated karma reason!
April 10, 2012 7:23:19 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

For me it was avast internet security opening in sandbox mode without me knowing it did, so i stoped it and the game loads up now.

 

Hope this helps

Reason for Karma (Optional)
Successfully updated karma reason!
April 10, 2012 10:33:11 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

i keep getting the black screen, i tried Navigate to C:\Users\[username]\AppData\Local\Ironclad Games\Sins of a Solar Empire\Setting. Open rebellion.user.setting using Notepad.  Change VideoIsWindowed to TRUE. Save and try loading the game. and it worked. game loads and works fine now. hope this helps

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 11, 2012 11:40:36 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

alienware m14x here with this problem.   running the exe directly rather than via steam works for me ( a bit glitchy on startup but it gets there eventually) .

 

no external monitors, as far as I am aware both chipsets are enabled, and I haven't tried disableing integrated graphics on the bios.

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2012 2:00:00 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I also have a alienware m14x, and running the exe directly doesnt work. No external monitors and both chipsets are enabled

Reason for Karma (Optional)
Successfully updated karma reason!
April 12, 2012 12:39:04 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Quoting hagnrn,
running the exe directly rather than via steam

 

How can you run the rebellion .exe without steam? Mine faults out when I got to the .exe location when I try that.

Reason for Karma (Optional)
Successfully updated karma reason!
April 14, 2012 6:25:50 AM from Stardock Forums Stardock Forums

I had this problem too.

 

Asus laptop with:

* NVidia GT555M

* Intel HD 3000 series integrated Graphics


First selecting to run on the NVidia GPU did not work. However, installing the NEW NVidia drivers did the trick to finally get rid of this bug! I now run driver version 296.10 and Rebellion on the NVidia GPU works like a charm, I hope this will help other people with this problem.

 

I downloaded them here: http://www.nvidia.com/Download/index.aspx?lang=en-us

Reason for Karma (Optional)
Successfully updated karma reason!
April 18, 2012 12:45:58 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Still unable to play due to "InPageError" even after recent update. Game just crashes after 10 minutes each time i play. Updated to new nvidia drivers as well - didn't make a difference.

 

Reason for Karma (Optional)
Successfully updated karma reason!
April 18, 2012 6:01:16 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Not sure if this is relevant at all, but I was getting this error after I disabled the password on my computer. This also stopped every other game from working though. Putting the password back on fixed this black screen error for me.

Again, I am not sure this could possibly be relevant at all.

Reason for Karma (Optional)
Successfully updated karma reason!
April 18, 2012 12:13:59 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I had the dreaded startup screen crash - was being caused by my virus checker. If you're using Avast!, try disabling it until next startup and trying the game again. Worked for me.

Reason for Karma (Optional)
Successfully updated karma reason!
April 19, 2012 1:02:06 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I do get a blackscreen but not at startup. It only seems to happen when two large fleets start fighting.

Reason for Karma (Optional)
Successfully updated karma reason!
April 24, 2012 10:18:00 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Posted this in the Beta Feedback, might make more sense for it to be here.

I play Sins on two computers, one is a home-built desktop, the other is a new HP laptop. Specs on both:

Desktop: AMD Phenom II BE 940 3.0Ghz, 6 GB DDR2, Radeon 5770

Laptop: Intel Quad i7m 2.2 Ghz, 8 GB DDR3, Radeon 7690m

Both are obviously quite capable of playing/running the game. I frequently get the black screen on startup of the game on the laptop and have to sleep the laptop and wake it up again before I can see the game. Also, alt-tabbing out of the game or hitting the Windows button frequently results in a black screen. I never have any problems with black screens on the desktop.

I have no idea if the difference between the computers is at all significant but I wanted to point this out in case part of the problem is the hardware difference. Also, this is obviously not just a Nvidia problem.

All drivers and such are up to date on both computers.

Reason for Karma (Optional)
Successfully updated karma reason!
April 24, 2012 11:21:28 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

No, there's something different going on with ATI users that we're not sure of (though most users are having the Nvidia bug). If you could send us your crash logs (if they're being generated) and dxdiag info, that would be great. 

Reason for Karma (Optional)
Successfully updated karma reason!
April 24, 2012 4:03:09 PM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

Most Nvidia users are or most mobile Nvidia users?  (running a desktop and have had no issues with graphics yet)

Reason for Karma (Optional)
Successfully updated karma reason!
May 11, 2012 4:51:49 AM from Sins of a Solar Empire Forums Sins of a Solar Empire Forums

I have this problem still as well.

Have not been able to play. I only have the Intel Integrated only, no other card. (Intel (HD) 3000)

So I guess it goes without saying that I do run through Intel Integrated. But still my problem persists.

 

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0005000   Page Render Time:
Facebook Twitter YouTube Google+