Stardock

Tiles cannot register behind Proxy

By on January 31, 2012 5:33:10 AM from Stardock Forums Stardock Forums

eveys

Join Date 11/2009
0

I've purchased Tiles to go on a Windows 7 64bit machine, download and install fine.

But I want to activate all the features I've paid for - so use the Configure Tiles > Add features > Activate existing purchases which pops up the login screen - enter login details correctly (Same as what I'm logged in with to write this post) and get message 'Incorrect email or password'.  I initially tried the Forgot password button which just replied with 'Unable to find your account details' - so looks like the app is unable to connect back to stardock.

The issue I strongly suspect is that the machine - like a lot of company machines - is behind a proxy.  I can run things like Steam fine from here as they take proxy settings or use IE's settings but cannot find any proxy settings for Tiles (Find this a bit strange for such a desktop application).

Is there a way (Without a third party proxy app) to get Tiles to work through a proxy?

If not, I can see the license key in my account - can I activate the Tiles app locally with this key,e.g. text file, just so I can unlock built in functionality?

Thanks

 

10 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
January 31, 2012 8:22:08 AM from WinCustomize Forums WinCustomize Forums

Does the add features page show the features you can purchase at all?

Reason for Karma (Optional)
Successfully updated karma reason!
January 31, 2012 8:27:37 AM from WinCustomize Forums WinCustomize Forums

Also if you purchased the full product vs just a feature you may find running TilesConfig ACTIVATE from a command prompt will allow you to activate ok.

Reason for Karma (Optional)
Successfully updated karma reason!
January 31, 2012 10:00:24 AM from Stardock Forums Stardock Forums

Thanks for the suggestion - add features page doesn't show any features.

Tried from the command line (Run as as administrator) TileConfig - produces dialog asking for my Stardock account email, password and serial - which I entered.  I then  get :

Error

 

NET001: Registration is unable to connect to the Internet to submit your information. Please check firewall/proxy settings and rerty.

 

I've made sure all the Tile exe's have access through the local firewall, also tried running through standard - no elevated -  console - still the same error.

Reason for Karma (Optional)
Successfully updated karma reason!
February 1, 2012 4:47:47 AM from WinCustomize Forums WinCustomize Forums

I'm having the exact same issue...any solution to this?? 

Reason for Karma (Optional)
Successfully updated karma reason!
February 1, 2012 10:35:31 AM from WinCustomize Forums WinCustomize Forums

We are looking into the issue as it seems to be a bug in the proxy handling code.

I will update this thread when I know more about the problem.

Reason for Karma (Optional)
Successfully updated karma reason!
February 1, 2012 1:09:41 PM from WinCustomize Forums WinCustomize Forums

Update : For those of you having proxy issues, can you download this : http://sd.stardock.com/SDDLCProxy.zip

Replace the SDDLC.dll file in your Tiles directory (C:\Program Files (x86)\Stardock\Object Desktop\Tiles on a 64 bit system) with the new one and see if the add features page now lists features.  If so see if the register existing purchases option now works too.

This will not alter the command line option so do not try that.

If this does not work, please let us know if your IE is set to auto configure mode, or with a specific named proxy and if it has an address for the auto proxy or not in IE settings.

Reason for Karma (Optional)
Successfully updated karma reason!
February 2, 2012 4:06:47 AM from WinCustomize Forums WinCustomize Forums

That worked a charm Thanks for the quick response!

Reason for Karma (Optional)
Successfully updated karma reason!
February 3, 2012 6:03:57 AM from Stardock Forums Stardock Forums

Brill - working now. 

Works with IE set to manual proxy settings  - 'use a proxy server' (Proxy host and port 8080 set), doesn't work though when using a PAC file 'use automatic configuration script'.  When set like the latter, in 'Add features' you get a message : 'The servers appear to be down right now.  Please try again later', may help to change the message along the lines of 'Unable to contact servers, can you browse the internet?  Are you using a proxy that needs to be set to manual in Internet Explorer' etc.  

 

Thanks for the fix - probably go and shove some more goodies onto it now.

Reason for Karma (Optional)
Successfully updated karma reason!
February 3, 2012 6:15:45 AM from Stardock Forums Stardock Forums

Actually just one further thing to add - with the proxy set right - when you click on 'View screenshot' for any of the items you get 'Unable to obtain screenshot'; checkout button does launch the card payment page but I haven't tried going beyond that.

Reason for Karma (Optional)
Successfully updated karma reason!
May 17, 2012 7:53:57 AM from Stardock Forums Stardock Forums
thanks .. this is what I'm interested
 
 
 
Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000656   Page Render Time:
Facebook Twitter YouTube Google+