Stardock

[Solution] Out of memory

By on August 24, 2010 9:12:03 AM from Elemental Forums Elemental Forums

Shaky010

Join Date 12/2007
+2

ATI video card users running Windows 7 64-bit need to update to the latest (post July 2010) video drivers. There is a bug in the pre-July drivers that causes a large memory leak.

73 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 9:14:49 AM from Stardock Forums Stardock Forums

Yes, supposedly it's a bug with 64 bit operating systems and ATI cards. I only have it happen like every 100 turns or so.

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 9:15:29 AM from Elemental Forums Elemental Forums

I get the same problem... don't worry I think the game is just suffering from some memory leaks or some such atm and hopefully it will be patched over the coming weeks.

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 9:16:28 AM from Elemental Forums Elemental Forums

Lucky for you I am getting it heaps, and bummer about being on win 7 64bit and ATI cards for me oh well fingers crossed this will get fixed up soon as it kinda sucks starting all over again..... though i am getting better with my starts now

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 9:26:20 AM from Elemental Forums Elemental Forums

I had it happen last night. I was just moving a unit and then it froze. It was my only CTD to date.

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 11:41:48 AM from Elemental Forums Elemental Forums

We've tracked it to an interaction between Havok and the ATI drivers, but if you guys can post your debug.err files they may still be helpful.

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 12:03:21 PM from Elemental Forums Elemental Forums

 I don't use ATI and I'm still getting the mem leak on Win 7 - 64 bit.  So it's not limited to you ATI users! 

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 12:06:09 PM from Elemental Forums Elemental Forums

Got an out out of memory error, as well.  Playing a large map, had 3 cities, and I was moving my sov group around the map (zoomed in a little - not far enough out to be using the cloth map) when it happened.  I'm on Win7 64-bit ultimate and have an ATI card.

Link to debug: http://pastebin.ca/1924308

 

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 12:15:38 PM from Elemental Forums Elemental Forums

Quoting kryo,
We've tracked it to an interaction between Havok and the ATI drivers, but if you guys can post your debug.err files they may still be helpful.

 

Me too! they will fix it soon maybe in a couple of days!

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 11:21:08 PM from Elemental Forums Elemental Forums

I hope they fix this soon I'm only on turn 399 on my game and it crashes every time I press the end turn button.

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 11:36:50 PM from Elemental Forums Elemental Forums

Oh and here is my debug.err file, http://pastebin.ca/1924820.

Reason for Karma (Optional)
Successfully updated karma reason!
August 24, 2010 11:51:55 PM from Elemental Forums Elemental Forums

Happened again

http://pastebin.ca/1924828

 

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 12:46:17 AM from Elemental Forums Elemental Forums

Even after the patch, keep getting these out of memmory crashes. I have win 7 64 with a I7 processor with 2 HD 5750 ATI cards in Xfire and my system has 6Gb of RAM

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 12:47:27 AM from Elemental Forums Elemental Forums

Note: If you have an ATI card with Win 7 64-bit (and WinVista 64) you need to update your ATI drivers to the latest version. This should solve the memory issue.

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 1:13:09 AM from Elemental Forums Elemental Forums

Here's my debug.err file from a recent crash (1.05)

http://dl.dropbox.com/u/9214597/Elemental1_05-2010-08-25T00-06-21-729.zip

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 1:27:12 AM from Elemental Forums Elemental Forums

I am having the same issue as Spadejack and my ATI drivers are completely up to date 

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 1:53:44 AM from Elemental Forums Elemental Forums

Frogboy:

- I play DoW which uses the Havok engine and I've never had out-of-memory issues before (this is campaign mode in DoW, mind you, I only play MP on my desktop). I also leave DoW minimized for literally HOURS and can come back and play just fine again. No mem leaks.

- For those with proprietary notebooks with discrete graphics cards, many vendors "lock" the video card drivers that you are allowed to use. This was fine, there was a few utilities out there that enabled you to hack the driver updates and make 'em work just fine. However, as of a few months ago, ATI Mobility Series driver updates were modified to be much less hackable. This means I'm stuck at my current ATI drivers with no way to update them. This is something that should be shared across a lot of people who use notebooks. 

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 2:03:20 AM from Elemental Forums Elemental Forums

Very recent ATi driver latest Elemental patch (1.05), out of memory CTD less than 20 mins ago. Debug.err here: http://pastebin.ca/1924887

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 2:46:05 AM from Elemental Forums Elemental Forums

Sorry Frogman, but that doesn't work. I have the latest Ati drivers on my win7 x64 with hd4890 and the problem is still there.

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 2:48:35 AM from Elemental Forums Elemental Forums

Yep, me too, i have the latest ATI drivers, same problem, out of memmory

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 3:07:41 AM from Elemental Forums Elemental Forums

Just patched to 1.05 and just rebooted from driver update (ATI), this is my latest out of mem crash report. This one happened after 20 minutes, I can't play the game currently.

 

http://pastebin.ca/1924907

 

My specs:

 

Intel core I7 2.67ghz

12gigs ram

Radeon  HD4850

Windows 7 64 bit

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 3:47:50 AM from Elemental Forums Elemental Forums

http://pastebin.ca/1924928

 

my specs:

 

Intel Cor i7 3.2ghz

12 gigs ram

Radeon HD 5970 2gb

Win 7 64bit

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 6:05:55 AM from Elemental Forums Elemental Forums

I'm still having this problem with the 1.05.016 hotfix'd update and the newest (10.7) catalyst drivers

From turn 189 to 190 memory usage jumps over 150 megs. Then from 190 to 191 another 100 megs. Ouch.

very few turns memory usage went down. But there were some turns that it did. Mostly just kept going up at around 10-20mb a turn.

total turns 178-235

C2D Q9550 @ stock
EVGA 780i mobo (original 780i, worst mobo i've ever gotten.)
Radeon 5850 1gb with 10.7 catalyst drivers (newest on main ati/amd site)
4 gigs of ram
Windows 7 64 bit

 

 http://pastebin.ca/1924989

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 6:54:07 AM from Elemental Forums Elemental Forums

just had this issue after turn 110

 

file link

http://filebin.ca/epmvqa

 

core i7 920 @ 3.4

ATI 5750 1gb with 10.7 drivers

6GB ram

windoes 7 64 bit

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 8:00:38 AM from Elemental Forums Elemental Forums

Why is this topic marked [Solution]? I've just had the same thing! 

And yes! My drivers ARE up to date, Latest patch as well.

 

http://pastebin.ca/1925029

 

Core i7 CPU

Ati 4800 HD GPU

6GB RAM

Vista 64 bit

 

This isn't resolved yet!

 

Thanks in advance,

 

Reason for Karma (Optional)
Successfully updated karma reason!
August 25, 2010 8:33:54 AM from Elemental Forums Elemental Forums

I built my computer last week so I'm sure the drivers are up to date.  I just had the device manager try and update it and it says it's at the most up to date driver.  Unless ATI came out with a new driver update in the last week or just didn't have the most up to date driver on their site when I downloaded it, I don't think that's the problem I'm having.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0001234   Page Render Time:
Facebook Twitter YouTube Google+