Stardock

SOLVED: blank/white paper icons Win7, after IconPackager uninstallation

By on August 16, 2010 8:00:53 AM from Stardock Forums Stardock Forums

SparticusX

Join Date 09/2008
0

So I just uninstalled IconPackager from Impulse and now almost all my icons are blank.
Not my Windows icons but all icons from installed program .exe's.
Shortcuts that are linked to them are also blank eg. on the desktop.
And some icons like .dll and .xml, even PhotoShop .psd's are now displayer as a colored shield like the one from Windows Firewall
Even the ones IP didn't even change before are messed up, like a 'screw you!' revenge after being dumped by the user.
I have the same problem on my laptop, and friends of mine are having this problem too.

I tried five different methods:

- odnt_zapper.exe (didn't work)
- Rebuild and repair the icon caches with IconPacker (didn't work)
- Installing TuneUp and Rebuild/Repair icons from there (didn't work)
- and I removed the IconCache.db file from C:\Users\<Username>\AppData\Local (didn't work)
- Manually create a .reg file and restore some of the Windows 7 icons. (no change so far..)
Like I said IconPackager screws up all your icons!

Re-installing Windows is not an option since I am on vacation and my friends are blaming me for this because I hooked them up on IconPackager.
Please someone tell me there is a working fix for this?!

OS: Microsoft Window 7 Ultimate x64
Latest IconPackager as of 16/08/2010 from Impulse

Yours sincerely,
Spart

================================================

EDIT: I found a fix!
Go to 'Start' open run command, type in Regedit.
In the new window of Registry Editor go to HKEY_CLASSES_ROOT\exefile\shellex and delete the subkey/folder 'IconHandler'

Problem solved, have a nice day!

5 Replies +2
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
December 20, 2010 11:21:45 PM from Stardock Forums Stardock Forums

Great post. I found this fix a while back and it worked like a charm but I just updated icon packager and to my surprise, the registry entry that is causing this problem is still part of the installation package. Does anybody from Stardock read these threads?

 

This is after applying the registry fix:

 

Reason for Karma (Optional)
Successfully updated karma reason!
January 11, 2011 1:00:54 PM from Stardock Forums Stardock Forums

I had the same thing happen but it was when I installed IconPackager, rather than uninstall it.  EVery icon that was not already part of ObjectDock disappeared!  Uninstalling restored the icons but I'd like to try IconPackager.  I wonder if the same registry fix will work for me on Vista and when it's installed.

Reason for Karma (Optional)
Successfully updated karma reason!
April 6, 2011 11:39:05 AM from Stardock Forums Stardock Forums

fabulous~~

so i can enjoy the iconpackager which is costed $9.5

thank you always!

Reason for Karma (Optional)
Successfully updated karma reason!
October 27, 2013 11:05:56 PM from Stardock Forums Stardock Forums

Thank you SpartacusX. Your solution fixed my problem!

Reason for Karma (Optional)
Successfully updated karma reason!
April 14, 2014 12:36:08 AM from Stardock Forums Stardock Forums

Thank you, thank you, THANK YOU,  I tried everything but your solution finally worked.

Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108433  walnut3   Server Load Time: 00:00:00.0000672   Page Render Time:
Facebook Twitter YouTube Google+