Stardock

GalCiv2/Dark Avatar on Vista

By on February 1, 2007 10:04:22 AM from GalCiv II Forums GalCiv II Forums

CariElf

Join Date 08/2001
+54

Update August 2007: If you are having memory issues on Vista, please read this Microsoft knowledgebase article:

http://support.microsoft.com/?kbid=938194

Update: June 2007: Version 1.6 of Galactic Civilizations II: Dark Avatar should have no problems at all on Vista at this point as long as your NVidia video card drivers are version 158.24 or higher.

If you have a laptop card, check the support section of your laptop manufacturer's website (Dell, hp, etc) for updated drivers.  If the driver version is not 158.24 or higher, you should contact your laptop manufacturer and ask them when updated drivers will be available. The more of you who contact them, the more incentive they have to update their drivers.  Otherwise, your only other option is to use the modified drivers from a third party site like LaptopVideo2Go, but this may void your laptop warranty so check the terms and conditions of your warranty first.

Update Mar 3 07: The 101.41 beta drivers appear to contain the fix for the issues discussed in this thread. If you are using an nVidia card with Vista, check nVidia's site for these drivers (or newer).

If you have a laptop and the manufacturer does not provide new enough drivers, try the ones here.

Update May 7 07: Version 1.6 beta 2 for Dark Avatar resolves the scrolling slowdown issue.

There is a known issue with GalCiv2 and Dark Avatar on Windows Vista and an NVidia video card. With the older version of the drivers, this could manifest as a crash or hang, or sometimes a hard lock. With the latest drivers for Vista, the game just stops repainting but can be shut down by hitting ALT+F4. It is typical of this error to see the message "Error flipping back buffer" in your debug.err file.

We are working with NVidia to resolve this issue. It may help if we send in the system information for additional systems, so if you encounter this error, please send your debug.err file to gc2bugs@stardock.com with the subject line "Vista NVidia error" or something along those lines so that I can quickly identify them and send them to my contact at NVidia. Dark Avatar and GalCiv2 have their own debug.err files, so make sure that you send the one where you got the error. Please only send in the report once.

You may also want to save your last autosave before the error so that you can test to make sure that new drivers have fixed the problem once NVidia has releases a new version, but you don't need to send in the save games at this time.

Currently, there are no known issues with ATI cards on Vista, but you may want to make sure that you have the lastest drivers anyway.

Please make sure that your debug.err file is included with any reports you send in, as SmartException is not currently attaching the debug.err file in its reports for Dark Avatar.

Update: NVidia has identified a problem in their drivers, which will be fixed in their next release.

231 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
February 6, 2007 6:57:39 PM from GalCiv II Forums GalCiv II Forums

My contact at NVidia thinks that he knows what the issue is, but he would still like for you to continue sending in your debug.err files.  I don't have any ETA of when new drivers might be available.

If you are not experiencing any errors playing either Dread Lords or Dark Avatar on Vista and you have an NVidia card, it may also be helpful for the NVidia driver developers if you send in your debug.err.  But please make sure to state in your e-mail that you are not having a problem as described above.

Thanks!

Reason for Karma (Optional)
Successfully updated karma reason!
February 13, 2007 6:55:47 PM from GalCiv II Forums GalCiv II Forums
Anyone know if the latest Vista driver (100.64) has fixed this issue? I am itching to play again!
Reason for Karma (Optional)
Successfully updated karma reason!
February 13, 2007 8:35:39 PM from GalCiv II Forums GalCiv II Forums
I downloaded and Installed 100.64 today it did not seem to solve the problem.

Oddly enough I am not getting the "Error flipping back buffer" in the debug.err however after the first turn it crashes. I do get a Windows error notifing me that GalCiv2 Dark Avatar has crash.
Reason for Karma (Optional)
Successfully updated karma reason!
February 13, 2007 8:59:05 PM from GalCiv II Forums GalCiv II Forums
Thanks!

Hopefully i can at least get into game that would be a triumph!
Reason for Karma (Optional)
Successfully updated karma reason!
February 14, 2007 8:07:40 AM from GalCiv II Forums GalCiv II Forums
Hmm...I don't see 100.64 either on the user or developer download site.  Where did you download them from?
Reason for Karma (Optional)
Successfully updated karma reason!
February 14, 2007 10:45:20 AM from GalCiv II Forums GalCiv II Forums
Right here : Vista 64 bit drivers and Vista 32bit drivers

Both are listed under the beta section
Reason for Karma (Optional)
Successfully updated karma reason!
February 14, 2007 2:54:12 PM from GalCiv II Forums GalCiv II Forums
I test those drivers too and nothing changed. I got a flip flap error as usual.

R: jarru
Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2007 12:05:03 AM from GalCiv II Forums GalCiv II Forums
Well, for me, the 100.64 drivers actually worked. I was able to start a game and played through a couple hundred turns without issue. The only 'problem' I had was that when quitting the system appeared to hang on the redraw. It took it a good couple minutes to release the resources and get Windows back, in stark contrast to the almost instant (and much improved over XP) release I have in every other game using Vista.

I'm running an 8800GTS on a C2D E6300 OC'd to 4GHz with 2GB Corsair DDR2-1000.

EDIT: And this was base GalCiv2, not DA.
Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2007 7:43:26 AM from GalCiv II Forums GalCiv II Forums

Well, I'm glad to hear that the problem was fixed for you at least!

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2007 11:31:28 AM from GalCiv II Forums GalCiv II Forums
No luck here either. I was able to play for a little bit longer but still had the same problem.   

Reason for Karma (Optional)
Successfully updated karma reason!
February 15, 2007 1:55:09 PM from GalCiv II Forums GalCiv II Forums
They worked for me in that I was able to play at least 25 or so turns before saving. Hopefully, I can get through a full game...exit was clean and no Flip error to be seen...phew.

Hopefully this gets resolved for everyone at some point as there appear to be lingering issues.

Those still having issues did you do a complete uninstall of the previous drivers?
Reason for Karma (Optional)
Successfully updated karma reason!
February 16, 2007 6:58:15 PM from GalCiv II Forums GalCiv II Forums
I completely uninstalled the old drivers; I used Driver Cleaner Pro too.

Reason for Karma (Optional)
Successfully updated karma reason!
February 18, 2007 6:45:28 PM from GalCiv II Forums GalCiv II Forums

I downloaded and Installed 100.64 today it did not seem to solve the problem.

Oddly enough I am not getting the "Error flipping back buffer" in the debug.err however after the first turn it crashes. I do get a Windows error notifing me that GalCiv2 Dark Avatar has crash.


I wasn't getting a debug.err file being generated until i played with the permissions of my galciv2 folder, try this:

Select the main galciv2 folder, right click, select the security tab and click all the allow boxes for "Users (name\users)" (on my system full control, modify and write wasn't allowed) and apply to all folders below it, the debug.err file should appear in the main game / DarkAvatar folder next time you encounter the problem.

Emailed my debug.err file in btw
Reason for Karma (Optional)
Successfully updated karma reason!
February 19, 2007 12:35:16 AM from GalCiv II Forums GalCiv II Forums
Downloaded new drivers, so I can *FINALLY* play, but when I exit the game everything's all screwed up, sorta like the same problem as before...super annoying! Plus the game runs SUPER choppy now (Athlon 2.4 GHZ, NVdia 7900, 1GB Ram) even with all the graphics turned down (both Gal Civ2 and DA)...any advice?
Reason for Karma (Optional)
Successfully updated karma reason!
February 19, 2007 11:03:46 AM from GalCiv II Forums GalCiv II Forums

My contact at NVidia is filing an official bug report with the 100.64 drivers since they have not fixed the issue, so they will be doing additional testing this week.

 

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2007 2:33:35 PM from GalCiv II Forums GalCiv II Forums

Great news!  NVidia has identified a problem in their drivers and the fix should be in their next release.

Reason for Karma (Optional)
Successfully updated karma reason!
February 20, 2007 5:57:22 PM from GalCiv II Forums GalCiv II Forums
Horray!

I'll be most looking forward to that. I am missing my GalCiv2 fix.

*eyetwich!*
Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 2:18:46 PM from GalCiv II Forums GalCiv II Forums
100.65 is out now! Is this the one already? Downloading...
Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 2:23:28 PM from GalCiv II Forums GalCiv II Forums

I don't know if 100.65 is the one or not, so let me know.  I'll start downloading it too, but you'll probably get it running before I do.

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 2:33:35 PM from GalCiv II Forums GalCiv II Forums
LordTheRon, did you get them off of 3DGuru or the NVidia website?
Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 3:41:40 PM from GalCiv II Forums GalCiv II Forums
I actually got them from laptopvideo2go.com (I have a Geforce 7300 GO in my laptop). Installed them but sadly still the same crash with the same error. Seems like we have to wait until the next release.
Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 3:45:29 PM from GalCiv II Forums GalCiv II Forums

There are no 100.65 drivers on NVidia's site so I would say that it is not an official release, and those appear to have been posted on the 17th, so that is definitely before NVidia found the problem.

 

Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 3:58:50 PM from GalCiv II Forums GalCiv II Forums
Yep I noticed. Sadly Nvidia doesn't support laptopcards directly so I have to get my downloads from laptopvideo2go.com. They mod the .inf files so you can use the normal drivers for your laptop. Oh well, let's hope it's in the next official release then and let's hope they bring it out quickly.
Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 5:19:14 PM from GalCiv II Forums GalCiv II Forums
http://www.nvidia.com/object/winvista_x86_100.65.html

They are on the official site just not linked from any page (found them by changing 100.64's url )

According the the readme file on the site the only change from the 64's is solving a bug in the nvidia control panel.

The wait goes on!
Reason for Karma (Optional)
Successfully updated karma reason!
February 21, 2007 11:21:06 PM from GalCiv II Forums GalCiv II Forums
Please, please tell me that GC2 and DA will work ok with Vista? I am building a new mega PC tomorrow evening (cost me a ton of money!) and it will use Vista 64-bit home premium. I am already starting to get concerned about vista and some of my games and I have not even installed it yet. I just hope my games all work ok I really do, especially DA.
Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108432  walnut2   Server Load Time: 00:00:00.0000734   Page Render Time:
Facebook Twitter YouTube Google+