Stardock.com ‚Äč

No Compatible devices found.

InitializeDirect3D Failed.

By on January 20, 2007 6:51:29 AM from GalCiv II Forums GalCiv II Forums

AWhitman

Join Date 04/2005
0
Hi,

I'm trying to run GalCiv2 on my Inspiron 8200 but when trying to run the game I just get a small black window and then nothing. I've pasted my debug.err file below and the error seems to be with my video card but looking through the forums a mobility 9000 will play the game ok. I realise the sound drivers are very old but they are the latest that Dell supply and as the error is about Direct3D not initializing I'd think that the sound drivers aren't the cause.

Suggestions would be much appreciated.


Debug Message: Version v1.4x last updated on: Mon Oct 23 17:43:56 2006
Debug Message: GalCiv2 is activated.
Debug Message: Checking DX Version.
Debug Message: *********DXDiag info follows.*********
System Info
Time: 1/20/2007, 11:36:41
DirectX Version: DirectX 9.0c (4.09.0000.0904)
Machine Name: PTERODACTYL
Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 2 (2600.xpsp_sp2_gdr.050301-1519)
Languages: English (Regional Setting: English)
System Manufacturer: Dell Computer Corporation
System Model: Inspiron 8200
BIOS: Phoenix ROM BIOS PLUS Version 1.10 A07
Processor: Mobile Intel(R) Pentium(R) 4 - M CPU 2.20GHz
Physical Memory: 512MB RAM
Page File: 193MB used, 1056MB available
Windows Dir: C:\WINDOWS


Display Info
Display device 1:
Device Name: \\.\DISPLAY1
Card Name: ATI MOBILITY RADEON 9000
Manufacturer: ATI Technologies Inc.
Chip Type: ATI MOBILITY/RADEON 9000 AGP (0x4C66)
DAC Type: Internal DAC(400MHz)
Key Device: Enum\PCI\VEN_1002&DEV_4C66&SUBSYS_00D41028&REV_01
Display Memory: n/a
Current Display Mode: 1600 x 1200 (32 bit) (60Hz)
Monitor Name: Default Monitor
Monitor Max Resolution:
Driver Name: ati2dvag.dll
Driver Version: 6.14.0010.6660
Driver Date: 12/17/2006 02:50:46
DirectX Acceleration Enabled: Yes



Sound info
Sound device 1:
Description: Crystal WDM Audio
Default Sound Playback: Yes
Default Voice Playback: Yes
Hardware ID: PCI\VEN_8086&DEV_2485&SUBSYS_59591013&REV_02
Manufacturer ID: 1
Product ID: 100
Driver Name: cwawdm.sys
Provider: Cirrus Logic, Inc.
Driver Version: 6.13.0010.4159
Driver Date: 8/8/2002 13:10:46
Type: WDM
Other Drivers:
Acceleration Level: 3
Cap Flags: 0
Min/Max Sample Rate: 0, 0



Debug Message: *********END dxdiag info.*********
Debug Message: Entering WinMain
Debug Message: ******* Starting Game Shell *******
Debug Message: Preparing to change display settings.
Debug Message: No compatible devices found.
Debug Message: InitializeDirect3D Failed.
Debug Message: Now windowed.
Debug Message: Shell initialization complete
Debug Message: WM_CLOSE message received.
Debug Message: GameUninitialize start
6 Replies
Search this post
Subscription Options


Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2007 7:49:00 AM from GalCiv II Forums GalCiv II Forums
Try editing the Prefs.ini file (located in My Documents\My Games\GalCiv2) and set the game resolution to your desktop resolution.

You would look for, and change to, this:

[Video]
DisplayWidth=1600
DisplayHeight=1200
ColorDepth=32
Fullscreen=1

And if it still fails, try setting Fullscreen=0.

And it sometimes helps to have the correct monitor driver installed - as opposed to a default driver. It may not be an issue in this case, but there is probably a more suitable driver for your (laptop?) monitor.

And I would also suggest you increase your swapfile to at least 2GB. This game can take a LOT of memory, especially with larger maps with a lot of planets. And having the swapfile static (as opposed to dynamic) is a good idea as well.
Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2007 9:24:40 AM from GalCiv II Forums GalCiv II Forums
Changing Prefs.ini made no difference other than a full black screen, still the same error in debug.err.

I can't find a way to change the monitor listing. In the advanced monitor settings I have "Default Monitor", "Digital Flat Panel (1600x1200)" and "Default Monitor". Attempting to update the drivers on the Default Monitor just results in Windows saying it can't find anything better than what is already installed. And yes, it is a laptop.
Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2007 12:24:29 PM from GalCiv II Forums GalCiv II Forums

I'd try changing your resolution to 1024x768 and make sure you're running with 32bit color mode and then try.

An ATI 9000 (ThinkPad T40) was my demo machine for the game  when I went out to the game mags so it should be fine.

Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2007 1:55:36 PM from GalCiv II Forums GalCiv II Forums
If the laptop came with a cd you would probably find the correct monitor driver on it.
Reason for Karma (Optional)
Successfully updated karma reason!
January 20, 2007 2:09:08 PM from GalCiv II Forums GalCiv II Forums
This isn't playing on an external monitor is it?
Reason for Karma (Optional)
Successfully updated karma reason!
January 21, 2007 11:27:27 AM from GalCiv II Forums GalCiv II Forums
Fixed it, turns out my driver install was hosed as no other direct3d applications worked either, I just hadn't used any for ages to notice. After a complete driver wipe and reinstall it all works fine.

Sorry to bother you.
Reason for Karma (Optional)
Successfully updated karma reason!
Stardock Forums v1.0.0.0    #108431  walnut1   Server Load Time: 00:00:00.0000219   Page Render Time:
Facebook Twitter YouTube Google+